Bem-vindos à nossa comunidade!

Junte-se a nós e faça parte hoje mesmo!

Aula: Formulário #01

JAlter4

Novo Membro
Cadastro
2/2/21
Postagens
4
Curtidas
2
Pontuação
3
Cidade
Natividade, RJ
Boa noite a todos! Estou com esse erro no formulário #01 onde o localhost:3003 não abre. Poderiam me dizer onde eu estou errando?erro_aaaa.png
 

Attachments

  • erro_2_aaaa.png
    erro_2_aaaa.png
    71,3 KB · Visualizações: 6
  • erro_3.png
    erro_3.png
    22 KB · Visualizações: 6

mourabraz

Membro
Moderador
Cadastro
23/12/20
Postagens
138
Curtidas
185
Pontuação
100
Cidade
Leiria
@JAlter4 Boa noite tudo bem?

Não seria esse https? acho que seria só com http mesmo!

Se não for avisa a gente!

Abraços.
 

over147

Membro
Cadastro
1/2/21
Postagens
26
Curtidas
34
Pontuação
39
Cidade
Fortaleza
E ai cara blz, você tem que descomentar a linha 5 do server.js
app.use(bodyParser.urlencoded({ extended: true }))

Esse body-parser vai dar ao express a habilidade de analisar o conteúdo das solicitações antes de fazermos alguma manipulação.
 

JAlter4

Novo Membro
Cadastro
2/2/21
Postagens
4
Curtidas
2
Pontuação
3
Cidade
Natividade, RJ
E ai cara blz, você tem que descomentar a linha 5 do server.js
app.use(bodyParser.urlencoded({ extended: true }))

Esse body-parser vai dar ao express a habilidade de analisar o conteúdo das solicitações antes de fazermos alguma manipulação.
Ah, eu fiz isso também (tinha comentado de novo pra ver se funcionava) mas segue dando esse erro. :(
 

Raquel

Membro
Moderador
Cadastro
24/9/20
Postagens
407
Curtidas
443
Pontuação
150
Boa noite a todos! Estou com esse erro no formulário #01 onde o localhost:3003 não abre. Poderiam me dizer onde eu estou errando?View attachment 176
Fala JAlter! Vi sua pergunta hoje na minha lista haha

Acabei de notar uma coisinha que não tinha notado lá na Udemy. No seu package.json estão faltando algumas dependências!

Faz o seguinte, apaga seu arquivo package-lock.json e a pasta node_modules, copia o package.json do repositório da Cod3r e salva em cima do seu, e instala novamente usando o npm i.

Ficamos no aguardo do resultado!

Abraços :)
 

JAlter4

Novo Membro
Cadastro
2/2/21
Postagens
4
Curtidas
2
Pontuação
3
Cidade
Natividade, RJ
Fala JAlter! Vi sua pergunta hoje na minha lista haha

Acabei de notar uma coisinha que não tinha notado lá na Udemy. No seu package.json estão faltando algumas dependências!

Faz o seguinte, apaga seu arquivo package-lock.json e a pasta node_modules, copia o package.json do repositório da Cod3r e salva em cima do seu, e instala novamente usando o npm i.

Ficamos no aguardo do resultado!

Abraços :)
Agora deu certo, muito obrigada! Acho que era erro do package mesmo. Muito obrigada!!
 

chriaalonso

Novo Membro
Cadastro
5/7/21
Postagens
1
Curtidas
0
Pontuação
1
Cidade
Osasco
Eu tb estou com esse problema. Mas, para mim informa que o bodyParser foi preterido. Fica com um risco em cima do bodyParser e informa que foir preterido ts(6385)
app.use(bodyParser.urlencoded({ extended: true }))
Alguma solução, por favor
 

Raquel

Membro
Moderador
Cadastro
24/9/20
Postagens
407
Curtidas
443
Pontuação
150
Eu tb estou com esse problema. Mas, para mim informa que o bodyParser foi preterido. Fica com um risco em cima do bodyParser e informa que foir preterido ts(6385)
app.use(bodyParser.urlencoded({ extended: true }))
Alguma solução, por favor
Fala chriaalonso! Tudo bom?

De fato foi, mas o bodyParser continua funcionando normalmente! Pode continuar o desenvolvimento do código tranquilamente.

Abraços e bons estudos!
 
Top