Bem-vindos à nossa comunidade!

Junte-se a nós e faça parte hoje mesmo!

Problema de versão de pacote

Francisco Avelar

Novo Membro
Cadastro
27/4/21
Postagens
2
Curtidas
5
Pontuação
7
Cidade
Santa Maria/RS
Fiz o curso de Docker. Na lição do "email-worker-compose", ocorreu um problema comigo ao conectar o PostgreSQL em Python com psycopg2.
Para fazer o curso, criei uma VM Debian em Windows 10 por meio do Hyper-V. Dessa maneira, o Docker executou em uma máquina virtual.

Versões
Hyper-V (versão 10.0.19041.1) em Windows 10
Máquina virtual Debian 10
Docker version 20.10.6, build 370c289
PostgreSQL 9.6.21
Python 3.6.13
pip 21.1 from /usr/local/lib/python3.6/site-packages/pip (python 3.6)

Durante o curso, a versão do pacote era psycopg2==2.7.1. O container python executava com erro no psycopg2.

Depois de muita pesquisa, consegui resolver o problema com psycopg2==2.7.3.2

Tomara que possa ajudar mais pessoas que venham a fazer o curso de Docker.
Valeu!
 
Top