Bem-vindos à nossa comunidade!

Junte-se a nós e faça parte hoje mesmo!

Requisito mínimo de um computador para programar com flutter

fernandocgiroto

Novo Membro
Cadastro
23/12/20
Postagens
3
Curtidas
2
Pontuação
3
Cidade
Lisboa
Estou fazendo o curso de flutter aqui da cod3r e venho usando o meu imac para acompanhar as aulas.
Entretanto eu estou querendo comprar um macbook ou um notebook e estou com medo que não rode tão bem na hora de compilar ou usar o emulador e já pensando no futuro, ter uma máquina que não me deixe na mão para futuros projetos.

Estou com duas dúvidas:
- Quais os requisitos mínimos para um computador portátil para desenvolver com flutter?
- Alguém sabe algo sobre esse novo processador M1 da Apple 8-Core se ele roda o android studio, o emulador e o virtual divice?

Obrigado!
 

Daniel

Estagiário da vida.
Moderador
Cadastro
24/9/20
Postagens
87
Curtidas
144
Pontuação
90
Cidade
Fortaleza
Fala, Fernando! Beleza?
Achei esses requisitos aqui que me parecem verídicos.

Para instalar o flutter no Windows, seu ambiente de desenvolvimento precisa atender aos seguintes requisitos:
  • Sistema operacional Windows 7 SP1 ou mais atual na versão 64bits.
  • 400 MB de espaço em disco para a instalação do SDK.
  • Windows PowerShell 5.0 ou mais recente.
  • Git for Windows versão 2.0 ou superior.
Sobre o novo processador da Apple, admito que meu conhecimento é limitado, mas li pela rede que ele superou o Intel i9 em alguns testes multicore e o i7 em testes single core. Posso até estar falando bobagem mas acredito que com esse processador fica de boas, contanto que você observe o gargalo da memória ram.

Alguém me corrija se tiver falado bobagem. hahahaha
Um abraço!
 

fernandocgiroto

Novo Membro
Cadastro
23/12/20
Postagens
3
Curtidas
2
Pontuação
3
Cidade
Lisboa
Opa Daniel, beleza!
Muito obrigado pela resposta.

Então, eu li que realmente a performance desse novo processador da apple está dando o que falar.
Mas como ainda estou iniciando os estudos e aprendendo a programação de app ainda não tenho muito conhecimento técnico, o que me deixa com alguns receios referente a esse processador:

- Estão dizendo que ele não tem compatibilidade com o virtual device do android Será que é algo que conseguiria contornar?

- Fico na dúvida se quero investir em algo muito caro e ser cobaia desse processador novo.
- Valeria mais a pena investir em um windows com a Microshit
 

Daniel

Estagiário da vida.
Moderador
Cadastro
24/9/20
Postagens
87
Curtidas
144
Pontuação
90
Cidade
Fortaleza
Cara, sinceramente, eu pesquisaria maneiras de contornar o problema. Embora nunca tenha tido uma máquina incrível como essa só ouço coisas boas dos desenvolvedores que utilizam MAC. O @Leonardo Leitão usa mac nos nossos cursos, talvez ele possa te falar algo sobre isso.
 

fernandocgiroto

Novo Membro
Cadastro
23/12/20
Postagens
3
Curtidas
2
Pontuação
3
Cidade
Lisboa
Last edited:

itajacy

Novo Membro
Cadastro
5/7/21
Postagens
1
Curtidas
0
Pontuação
1
Cidade
limeira
Olá,

Essa é a minha primeira vez aqui no fórum, então não sei se é aqui que deveria colocar as minhas dúvidas, mas como eu vi que vocês já usam Flutter, talvez possam me ajudar.

tenho algumas dúvidas quanto ao equipamento necessário, se vocês souberem e puderem responder eu agradeço.

Estou começando a estudar o flutter, tenho um notebook com windows e está rodando perfeitamente e ao invés de usar o emulador, conecto um celular android e mando rodar direto nele.
Vamos as dúvidas:

1 - Ouvi dizer que para conseguir instalar o programa em um iphone, é necessário ter um mac (imac, macbook), isso é verdade?

2 - Se eu tivesse uma macbook ao invés de um note com windows, eu conseguiria emular direto em um celular com android?

2.1 - Se com um macbook for possível emular / instalar os apps ios/android um macbook pro entre 2015/2017 com 8gb e ssd rodaria tranquilo, qual seria a versão
a versão do ios indicada?
 
Top